KMPlayerㅣForum
Korean Download Skins Testimonials User Map RSS
Post problems you have when using kmp.
Page 2 of 2: < 1 2
View First Unread   Thread Tools Linear ModeHybrid ModeThreaded Mode
New Member
 
Join Date:  Mar 2007
Location:  mexico
Posts:  2
#11 | Link | Posted 03-08-2009
change the permissions of the kmplayer folder in program files for the users group, add total control, write and modify that worked for me
New Member
 
Join Date:  Feb 2009
Posts:  8
#12 | Link | Posted 08-21-2009
Been running Windows 7 for a wile. Before that, Vista.
This problem never come up till very( day before this post) recently.
I tried to backtrack what has changed with the configuration as to before the error and it suggests that iTunes is the cause or participant.
I am not sure what gen_ml.dll is calling when starting, but iTunes seems to be causing audiodg.exe to crash periodicaly as well. My Realtek audio driver "is" Win7 compatible..

Its an annoying problem if you don't know what is happening and Windows 7 does not popup an error on this. It just keeps KMP tucked away in the taskbar.

I renamed the dll and all works fine.

Just wanted to let you know.
New Member
 
Join Date:  Dec 2009
Posts:  1
#13 | Link | Posted 12-09-2009
I have kmplayer 2.9.4.1436 and winwows 7 Prof., and I got the same error everytime I started kmplayer.
Problem got solved, when I gave kmplayer directory 'modify right' to users.
As I understood, it's because of that all programs run with users' rights even if you are logged in with admin account.
New Member
 
Join Date:  Dec 2009
Posts:  1
#14 | Link | Posted 01-07-2010
Quote:
Originally Posted by ksandrZ View Post
I have kmplayer 2.9.4.1436 and winwows 7 Prof., and I got the same error everytime I started kmplayer.
Problem got solved, when I gave kmplayer directory 'modify right' to users.
As I understood, it's because of that all programs run with users' rights even if you are logged in with admin account.
I use windows 7 too and had the same problems.
I did as you told. And it is solved!!

Thanh you!
New Member
 
Join Date:  Sep 2007
Posts:  1
#15 | Link | A Possible Fix, Posted 01-22-2010
I concur that the source of "Access Violation" on startup of The KMPlayer is due to the incompatibility of Winamp plug-ins (e.g., Enhancer v.0.17) with operating systems following Windows XP (Windows Vista/7).

Here are solutions that allowed me to properly play The KMPlayer WITH Enhancer v.0.17 Winamp plugin on Windows 7 without deleting any registry keys or running the application in XP mode.

Problem: The error message Access violation at address ######## in module 'gen_ml.dll. Read of address ########. occurs when attempting to open The KMPlayer WITH Enhancer v.0.17 Winamp plugin enabled.

Solution: Rename the file dsp_enh.dll in Local Disk (C:)/Program Files/The KMPlayer/PlugIns folder to dsp_enh1.dll.

This will allow the Enhancer plugin window to appear for temporary use until The KMPlayer is closed. However, plugin settings will not be saved, even if the application is run as an administrator. For a permanent solution, apply the Permissions setting (Solution 2) as outlined in the following situation below.

Reference: Leo's Lyrics Forums



Problem: The error message Error: Can't access registry information... appears at startup of The KMPlayer WITH Enhancer v.0.17 Winamp plug-in enabled.

Possible cause: The user does not have permission to read the registry entry for the Enhancer software.

Solution 1:
Right-click The KMPlayer application icon and select Run as administrator.

Solution 2 (Preferred):
Open Registry Editor (go to Start, type regedit in search bar; or go to Start > Accessories > Run, type regedit), press OK).




In Registry Editor, go to HKEY_LOCAL_MACHINE\SOFTWARE\Ioscasoft. Right-click the Iocasoft folder and select Permissions...




In the security window dialog, under Group or user names:, click on Users, and check the boxes for Full control and Read (under Permissions for users).




Click OK. And exit the Registry Editor.

This will allow non-administrator users to read registry files associated with Iocasoft, which in this case is the Enhancer plugin. In other words, applying this Permission setting will remove the Error message upon opening The KMPlayer and save user settings for the plugin.

Reference: WINAMP.COM forums


Finally, I must stress the importance of choosing the correct output speaker configuration that best matches your speaker setup (see Preferences > Audio Processing > Resample/Output > Output, and choose your speaker configuration from the drop-down list). When playing audio files, although I could hear sound emitted from my speakers, I did not notice the Enhancer plugin effect until I chosed the correct speaker setup.
Last edited by GTB : 01-23-2010 at 01:02 PM.
marchesi's Avatar
New Member
 
Join Date:  Jul 2009
Posts:  10
#16 | Link | Posted 04-07-2010
Hello,

from a week ago, whenever KMPlayer starts, it gives the creepy 'access violation' welcome screen. Tried to uninstall/install, no good.

It's also happening when switching from full screen to windowed, and sometimes
when pressing spacebar (pause).

Thing is it ran smoothly for a long time (months), now this. Is there any
codec interaction I should be aware of, meaning if I install another players,
like MPC, or games, something could be jammed off? Would it be needed a registry
housekeeping??

On top of that, the already reported 'green bars' are showing for no apparent
reason, sometimes you open a divx file, there they are. Other times, they
don't come up. Already checked renderers and external filters, everything
seems to be okdok.

Thanks,
Xezi
Machine: M4A78-EM / 2x2G Corsair XMS2 6400 / Athlon II X4 620 2.6GHz
OS: Windows Seven ultimate x64 6.1.7601 SP1 7601
Video: Philips 47PFL7403
Audio: SPDIF coax - Philips HTS3365X 5.1
Players: KMPlayer 3.1.0.0 / Media Player Classic HC x64 1.5.2.3456 / VLC 1.1.11
Filters: AC3Filter 1.63b / CoreAVC professional 3.0.1
Splitter: Haali Matroska splitter 08-sep-2011
New Member
 
Join Date:  Jul 2009
Posts:  1
#17 | Link | Posted 04-11-2010
i had this problem too, i just deleted all gen_ml related files [gen_ml.dll , gen_ml.dll_ , gen_ml.ini] and it is running ok now
Thread Tools
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Supported by PANDORA.TV
All times are GMT +9. The time now is 06:39 PM.
Contact Us - The KMPlayer - Archive - Top