KMPlayerㅣForum
Korean Download Skins Testimonials User Map RSS
Page 1 of 2: 1 2 >
View First Unread   Thread Tools Linear ModeHybrid ModeThreaded Mode
New Member
 
Join Date:  Sep 2008
Posts:  5
#1 | Link | ATI-Ressourcen nutzen, Posted 09-18-2008
Ich hatte alles mal prima am Laufen, nun bekomme ich diese Problem nicht mehr in den Griff: Kann mir Jemand auf die Schnelle einen Tipp geben, wie ich bei HD-H.264-Streams den KM-Player wieder dazu kriege, die GPU-Ressourcen meiner ATI 3850 zu nutzen?

Ich hatte bereits bei Videoverarbeitung "Deaktivieren" bei H264-Wiedergabe vorgegeben und bei "Externe Video-Decoder" die H264-Wiedergabe auf "Systemvorgabe" gesetzt. So lief dann alles problemlos bei 8 %-CPU-Last und völlig ruckelfrei.

Inzwischen habe ich wieder einige Parameter geändert, und bekomme nun den Urzustand nicht mehr hin. Nun greift der Player immer auf die PowerDVD-Dekoder zu und bei rund 70 %-CPU-Last läuft alles nicht mehr flüssig.

Hat zufällig Jemand seinen KM-Player auf die ATI-Karte abgestimmt und kann mir einen Tipp geben?
bastik's Avatar
German moderator
 
Join Date:  May 2008
Location:  Germany
Posts:  3,993
#2 | Link | Posted 09-19-2008
Ich wünschte ich könnte dir in diesem Fall wirklich helfen.... Wie gesagt.. ich wünschte.

Möglicherweise hilft dies (eng) :
http://www.kmplayer.com/forums/showt...4182#post24182

Ansonsten alles auf Anfang und dann noch mal so machen, wie es zu erst war.
Please read this before you post and use the Forums Search. Read other sticky threads, too. Thank you.
--
Impurities make things work and sometimes unique.
bastik's Avatar
German moderator
 
Join Date:  May 2008
Location:  Germany
Posts:  3,993
#3 | Link | Posted 09-20-2008
Wenn jemand helfen kann, so möge er dies doch bitte tun. Danke.

heimkino2008, wenn du es schaffst, bitte berichte von deinem Erfolg, dann haben vlt noch mehr Nutzer etwas davon. Danke.
Please read this before you post and use the Forums Search. Read other sticky threads, too. Thank you.
--
Impurities make things work and sometimes unique.
New Member
 
Join Date:  Sep 2008
Posts:  2
#4 | Link | Posted 09-23-2008
Ich gehe mal davon aus, du meinst DXVA. Dazu muss
  1. dein Stream auch mit dem entsprechenden Profil codiert sein, da nicht sämtliche Codec-Features unterstützt werden
  2. darüberhinaus musst du bei VISTA den EVR Custom Renderer oder bei XP den VMR9 renderless verwenden
Ich selbst bin von der Verwendung von DXVA abgekommen. Die besten Ergebnisse habe ich bei Verwendung des CoreAVC 1.7 als "externer Codec" sowie Direct3D-Yuv als Renderer (Da ist auch schwarz schwarz. Sieht um Welten besser aus als DXVA. Damit komme ich mit einem C2D@6300 und einer ATI HD 2600 auf 30-50% Systemlast bei 1280x720 und bis 80% bei 1920x1080 auf meinem 42" Toshiba.
Letztendlich ist es egal wer den Strom verbrät, die Graka oder die CPU.

Gruß
TTPlayer
New Member
 
Join Date:  Sep 2008
Posts:  5
#5 | Link | Posted 10-02-2008
Der KM-Player kann einem schon wirklich den Schlaf rauben, Leute, aber ich mag ihn trotzdem (oder gerade, weil er so zahllose Features beinhaltet).

Im Moment bin ich bei H.264-Material absolut glücklich. Es läuft alles ruckel- und störungsfrei, bei exzellentem Sound. Dabei ziehe ich die TS-Files meines Technisat HD-S2 einmal durch den TS-Remux bzw, wenn die Datei von TS-Remux nicht geschluckt wird, vorab durch den H264-Cutter und dann (damit der KM-Player die Datei schluckt), hernach nochmal schnell durch den TS-Remux.

Die nun endgültige (!) Kombi bei mir (unter Vista) ist der Gabest-Splitter, Vistas EVRenderer (der endlich das lästige Ruckeln an meinem Standard-LCD Toshiba WL66 abstellte, was unter XP als sporadisches Ruckeln eine Katastrophe war), ffdshow-Audiodekoder (rev 2156 beta von September 2008), Reclock 1.18.13 beta von September 2008 für Vista (läuft exzellent als immer grün anspringende Uhr!) und Cyberlinks H.264/AVC-Dekoder PDVD8. Dem Player habe ich Hohe Priorität eingeräumt und den Super-Speed-Modus aktiviert.

(PS: Reclock ist im Grunde bei meiner Vista-Geschichte nicht nötig, ich "stehe" aber auf den exzellenten Direct-Sound dieses Renderers und letzte wenige Mikroruckler bei H.264-Material bekomme ich so auch noch weg.)

Bei H.264-Material habe ich im Player vorgegeben, die oben genannten Externen Dekoder zu benutzen, was er auch tut. Nun bin ich endlich wieder bei rund 10 bis 12 %, manchmal nur noch 8 % CPU-Last, was nahe legt, dass nun (wie gewollt) die ATI-Karte die Arbeit macht - was unter PowerDVD bekanntlich "Hardwarebeschleunigung" heißt und im KM-Player mit Cyberlinks H264-Dekoder dann auch nutzbar ist.

Nun könnte man fragen, warum ich dann nicht gleich unter PowerDVD die Files anschaue. Ich habe den selben Film unter PowerDVD8 angeschaut und unter KM-Player. Unter PowerDVD8 gab es sporadische Aussetzer, Bildstörungen und schon ein leichtes Spulen oder Bedienen der Pause-Taste konnte den Film zum Absturz bringen. Der KM-Player ließ sich durch rein gar nichts (!) aus der Ruhe bringen. Ein Traum, wie die Files durchrutschten. Einziger Wermutstropfen sind die fast 5 Sekunden langen Pausen beim Wechseln in der Playliste zur nächsten Datei. Nahtloses Playback ist nicht möglich.

Noch besser gefällt mir das HD-Bild, wenn ich den ffdshow-Videodekoder für H.264-Material vorgebe. Dann ist zwar keine Luft mehr für Bildmanipulationen via ffdshow (weil dann dem PC die Puste ausgehen würde), doch ohne solche Vorgaben läuft bei rund 40 bis 60 % CPU-Last alles ebenfalls flüssig und ruckelfrei. Wobei natürlich für Extra-Mätzchen wie Vorspulen und dgl. (im Vergleich zum Cyberlink-Dekoder) keine Luft mehr ist. Aber das Bild erscheint mir ein Quentchen schärfer zu sein.

Generell: Das ist alles bei mir Herumspielerei, aber nun bin ich mit dem Resultat zufrieden. Auch bei meinen SD-ts-Files nutze ich ausschließlich ffdshow, dann aber auch die Möglichkeit der Bildmanipulation, was spürbar mehr Schärfe, Bildtiefe und Bildruhe liefert.
New Member
 
Join Date:  Sep 2008
Posts:  5
#6 | Link | Posted 10-02-2008
@ttplayer

Deine Kombi werde ich auch mal antesten. Gibt ja eine Trial-Version CoreAVC. Ich zieh' heute mal nen Platten-Image und dann teste ich das mal. Auch bei mir fahre ich 1280x720p50 mit einer ATI 3850. Wenn ich schon so viel geld ausgegeben habe, soll die GPU auch was tun, finde ich ;-) .
New Member
 
Join Date:  Sep 2008
Posts:  5
#7 | Link | Posted 10-02-2008
@ttplayer

Wollte noch nachschieben, Dein Hinweis auf den CoreAVC 1.7 war Gold wert! Ich hatte zwar von diesem Codec schon oft gehört, aber nie wirklich erlebt. Dieser Codec ist der Hammer, jedenfalls was mein spezielles Problem angeht und kam in letzter Sekunde: Ich verfüge über zahlreiche Mitschnitte aus Premiere HD, die ich alle demnächst löschen wollte. Denn der Cyberlink H264-Dekoder PDVD8 und auch PDVD7 hingen sich im TS-Stream stets an bestimmten Stellen auf, nur der Ton lief weiter.

Mit ffdshow schaffte ich es zwar, diese bestimmten Abschnitte der Filme zu passieren, danach aber liefen Bild und Ton auseinander. Nur aus Interesse schaute ich die selben Filme und Passagen gestern bei Einbindung der Trial-Version von CoreAVC 1.7 professionell. Absolute Sahne! Nicht den geringsten Ausfall.

Mehr noch: Sogar ffdshow durfte sich einklinken und ein paar bescheidene Parameter bezgl. des Bildes waren auch noch möglich. Undenkbar vorher! Eine Wiedergabe war gleich zu Beginn nicht möglich. Zwar schwitzen bei dieser Kombi jetzt beide CPU-Kerne bei bis zu 80 % Last. Aber wen juckt das, wenn alles flüssig läuft?!?

Nur ein Problem bleibt: Auf den KM-Player kann man einprügeln wie man will, er weigert sich standhaft, CoreAVC 1.7 als externen Dekoder zu verwenden, wenn Cyberlinks Dekoder auf dem System aktiv ist. Erst, wenn ich diese Dekoder vorübergehend deaktiviere (was ja kein Dauerzustand sein kann), darf der CoreAVC 1.7 im KM-Player werkeln.

Ich fuhr also die Tests gestern mit dem Mediaplayer classic homecinema. Mein Fazit: Die 14 $ für den CoreAVC 1.7 sind echt gut angelegtes Geld. So souverän habe ich noch keinen H264-Dekoder werkeln gesehen.
New Member
 
Join Date:  Sep 2008
Posts:  2
#8 | Link | Posted 10-06-2008
@Heimkino2008
Dein Problem mit dem CoreAVC / PDVD Filter im KMPlayer kann ich nicht nachvollziehen. Mein System verwendet immer den Filter, den ich bei den externen Codecs einstelle (habe nämlich auch beide installiert!!). Vielleicht solltest du mal mit dem Filtermanager (Manager für eigene Filter / Filtermanager) die Merrit-Werte der Codecs tunen.
Und nicht vergessen den Haken in den Config-Seiten des Coreavc auf "Preferred Decoder" zu setzen.
Gruß TTPlayer
New Member
 
Join Date:  Sep 2008
Posts:  5
#9 | Link | Posted 10-08-2008
Den CoreAVC wollte ich schon mehrfach als Preferred Decoder markieren, der Haken wird aber immer wieder entfernt. Vielleicht ist diese Funktion unter Vista nicht verfügbar?!? Ich denke, dass Du deshalb auch im KM-Player keine Probleme hast und der Player dann diesem Vermerk folgt.

Bei mir jedenfalls kann ich die Box solange auf checked setzen wie ich lustig bin, es ist beim nächsten Aufruf stets alles entfernt :-(.
New Member
 
Join Date:  Oct 2008
Posts:  2
#10 | Link | Posted 10-25-2008
Moin zusammen! Ich möchte auch gerne die Ressourcen meiner ATi 3850 nutzen. Mit dem MPC (CPU Auslastung maximal 7%) klappt alles wunderbar aber leider nicht mit dem KMplayer (CPU Auslastung 58%). Wo genau mach ich die Einstellungen beim Kmplayer, ich verzweifle langsam....
Thread Tools
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Supported by PANDORA.TV
All times are GMT +9. The time now is 01:01 PM.
Contact Us - The KMPlayer - Archive - Top