KMPlayerㅣForum
Korean Download Skins Testimonials User Map RSS
Found a reproducible bug in kmp? Report it with detailed things.
Page 1 of 2: 1 2 >
View First Unread   Thread Tools Linear ModeHybrid ModeThreaded Mode
Member
 
Join Date:  Jun 2007
Posts:  35
#1 | Link | 2.9.3.1431/1432 randomly exits while Delphi7 or 2.9.3.1428 works stable, Posted 06-16-2008 Quote
This bug is movie format independent. After approx 10-30 min 1431 exits in random places, both with internal and external codecs, but 1428 never does it and works right. 1431 just silently exits, no message/window/log etc, playing from the exit place works (for a while, until next exit).

WinXP Pro SP3, Catayist 8.5, Overlay Mixer
Last edited by Ache : 08-02-2008 at 01:57 PM.
bastik's Avatar
German moderator
 
Join Date:  May 2008
Location:  Germany
Posts:  3,993
#2 | Link | Posted 06-17-2008 Quote
I experienced with the same problem (found in audio-mode) but it just disappeared.
z's Avatar
- Panthera tigris -
 
Join Date:  Jan 1970
Location:  Heaven
Posts:  7,280
#3 | Link | Posted 06-28-2008 Quote
Can you make steps to the bug? Just going back to the previous would not improve the situation if you have a plan to future update..
Do to others as you would be done by. Luke 6:31
READ THIS FIRST BEFORE POSTING !!!
Member
 
Join Date:  Jun 2007
Posts:  35
#4 | Link | Posted 06-28-2008 Quote
What speps you want? If you'll have, say, debugging version which will catch its own silent exit and dump something useful on it, I can test it and report back.

I found no specific things this bug depend (excepting player version), it happens with any format and any setup.
z's Avatar
- Panthera tigris -
 
Join Date:  Jan 1970
Location:  Heaven
Posts:  7,280
#5 | Link | Posted 06-28-2008 Quote
The problem is I can't reproduce your problem in my side with the latest beta. Did you follow the steps described in the sticky thread? You probably have the problem for some reason. However, the problem which is not figured out clearly would not be fixed at all as we don't know it.
Do to others as you would be done by. Luke 6:31
READ THIS FIRST BEFORE POSTING !!!
Member
 
Join Date:  Jun 2007
Posts:  35
#6 | Link | Posted 06-28-2008 Quote
Quote:
Originally Posted by z View Post
Did you follow the steps described in the sticky thread?
Almost Excepting:
1) Ctrl-Tab info:
Since I try to change everything, only system info is relevant. The needed system info (but for 1428 to which I switch back) just posted to "wrong MP3 time" thread. If you say, I can reinstall 1431 again and post its own.
2) Small sample of file:
Any piece of any video file in any format ~40min length - you don't need mine.
I have big collection of various different formats - all trigger that (even playing DVD).
Member
 
Join Date:  Jun 2007
Posts:  35
#7 | Link | Posted 08-02-2008 Quote
More news. I notice the same random exit in 1432 (R2) Delphi2007 version, but the same Delphi7 version plays normally.
bastik's Avatar
German moderator
 
Join Date:  May 2008
Location:  Germany
Posts:  3,993
#8 | Link | Posted 08-02-2008 Quote
maybe I should have posted here what I posted there

http://www.kmplayer.com/forums/showthread.php?t=10404
Please read this before you post and use the Forums Search. Read other sticky threads, too. Thank you.
--
Impurities make things work and sometimes unique.
Member
 
Join Date:  Jun 2007
Posts:  35
#9 | Link | Posted 08-06-2008 Quote
Quote:
Originally Posted by bastik View Post
maybe I should have posted here what I posted there
It seems your exits related to mp3 files only and/or crossfader while mine ones for all file types without crossfader and apparently Delphi7 vs Delphi2007 thing.
bastik's Avatar
German moderator
 
Join Date:  May 2008
Location:  Germany
Posts:  3,993
#10 | Link | Posted 08-07-2008 Quote
Quote:
Originally Posted by Ache View Post
It seems your exits related to mp3 files only and/or crossfader
You are right. My exits are related to the crossfader. Maybe it would have required a new thread.

BTW: What is newer? Delphi 7 or Delphi2007?
Please read this before you post and use the Forums Search. Read other sticky threads, too. Thank you.
--
Impurities make things work and sometimes unique.
«Previous Thread | Bug Reports | Next Thread»
Page 1 of 2: 1 2 >
Thread Tools
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Supported by PANDORA.TV
All times are GMT +9. The time now is 01:08 PM.
Contact Us - The KMPlayer - Archive - Top