KMPlayerㅣForum
Korean Download Skins Testimonials User Map RSS
Found a reproducible bug in kmp? Report it with detailed things.
Page 1 of 2: 1 2 >
View First Unread   Thread Tools Linear ModeHybrid ModeThreaded Mode
New Member
 
Join Date:  Apr 2009
Posts:  5
#1 | Link | KM player freezes bad.., Posted 04-23-2009 Quote
HI!

I've been looking for a few hours for a solution too my problem, here it is:

When I play a video file and close it or it ends.. the program freezes.. I try to close it windows vista (32 bit) says program not working.. I press shut it now.. nothing happens.. I do the usual thing I do when this happens.. ctrl+alt+delete.. and then the computer freezes entirely.. every time it's the same thing.. I've tried 1434 and 1435.. gonna do a last desperate atempt at 1433 but I doubt it'll work..

Please help me out C-('_'Q)
pungaka's Avatar
KMP System Crasher =p
 
Join Date:  Dec 2008
Posts:  30
#2 | Link | Posted 04-23-2009 Quote
hi strafjen,

I need to know your system specs when you play a movie on it.

Try to play a movie and press ctrl+tab and you will get the movie info. Copy it and paste it to these thread.

In some case scenarios, since you are using windows vista, sometimes, system specification or hardware is a matter of concern. (Vista should be operating with a 2GB MEMORY, 2GHZ PROCESSOR ABOVE, INTEL GMA X3100 GRAPHICS CARD TO ULTRA HIGH END VIDEO CARD OF NVIDIA OR ATI.)

Additional info:

Version 1434 is the stable build so, 1435 is dependent for now in a system specs since these is considered "pre release or alpha version" as informed.
KMPlayer plays together, tweaks together
New Member
 
Join Date:  Apr 2009
Posts:  5
#3 | Link | Dunno which part so I'm posting everything I got when ctrl+tab, Posted 04-23-2009 Quote
Quote:
Originally Posted by pungaka View Post
hi strafjen,

I need to know your system specs when you play a movie on it.

Try to play a movie and press ctrl+tab and you will get the movie info. Copy it and paste it to these thread.

In some case scenarios, since you are using windows vista, sometimes, system specification or hardware is a matter of concern. (Vista should be operating with a 2GB MEMORY, 2GHZ PROCESSOR ABOVE, INTEL GMA X3100 GRAPHICS CARD TO ULTRA HIGH END VIDEO CARD OF NVIDIA OR ATI.)

Additional info:

Version 1434 is the stable build so, 1435 is dependent for now in a system specs since these is considered "pre release or alpha version" as informed.
Code:
[Primär filtergraf]
0) - XXX.avi
1) - AVI Splitter
2) - KMP Video Codec
3) - KMP Audio Codec
4) - OverlayMixer
5) - Video Renderer
6) - Default DirectSound Device

[Videoinfo]
avkodare -(XVID) KMP Video Codec(Xvid-libcodec.dll)
Format -Major Type: Video - Sub Type: YUY2
VideoInfo: YUY2 640X-352, 16 bits

[Ljudinfo]
avkodare -(0x55) KMP Audio Codec(MP3 Audio-libmad.dll)
Format -Major Type: Audio - Sub Type: PCM
WaveFormatEx: ExtPCM(0xFFFE), 48000 Hz, 16 Bits, 3 Ch

[Basvideo-DSP]
+All Video DSPs are disabled!
Internal brightness: 100%

[Avancerad video-DSP]
+All Video DSPs are disabled!

[Ljud-DSP]
+All Audio DSPs are disabled!
+Pre amplification: Main: (100%)
+Auto Volume Control

[Inställningar för undertexter]
+Draw Mode(Selected): Overlay
+Draw Mode(In use): On Overlay
+Text Rendering Method: Window(GDI)

[KMPlayer]
+Version: 2.9.4.1433(6 369 792, 2008-10-15 08:30:38)
+libcodec.dll: Exist(4 225 536, 2008-07-11 07:59:56)
+libmplay.dll: Exist(431 616, 2008-07-14 04:31:44)
+PProcDLL.dll: Exist(1 769 472, 2008-02-25 08:07:04)
+LibDTS.dll: Exist(144 384, 2008-02-25 08:06:28)
+liba52.dll: Exist(41 472, 2008-07-08 12:09:42)
+libfaad2.dll: Exist(287 744, 2008-07-08 12:07:22)
+libmad.dll: Exist(88 064, 2008-07-08 12:10:06)
+libmpeg2.dll: Exist(116 224, 2008-07-08 12:10:20)
+theora.dll: Exist(152 576, 2008-07-08 12:10:44)
+OggVorbis.dll: Exist(1 165 312, 2008-02-25 08:07:00)
+xviddll.dll: Exist(678 400, 2008-07-08 12:15:36)
+Old_QUARTZ.DLL: Exist(770 048, 2008-02-25 08:07:00)
+AboutDll.dll: Exist(105 472, 2005-10-03 07:12:18)
+DTView.dll: Exist(104 448, 2008-02-25 08:04:36)
+MPlayer.dll: Missed
+ImLoader.dll: Exist(856 064, 2008-02-25 08:05:22)


--------------------
[Filinfo]
--------------------
D:\XXX
    Complete name : D:\XX
    Format : AVI
    Format/Info : Audio Video Interleave
    File size : xxx MiB
    Duration : 23mn 12s
    Overall bit rate : 1 405 Kbps
    Writing application : transcode-1.0.2
  Video
    Format : MPEG-4 Visual
    Format profile : Streaming Video@L1
    Format settings, BVOP : Yes
    Format settings, QPel : No
    Format settings, GMC : No warppoints
    Format settings, Matrix : Default
    Muxing mode : Packed bitstream
    Codec ID : XVID
    Codec ID/Hint : XviD
    Duration : 23mn 12s
    Bit rate : 1 233 Kbps
    Width : 624 pixels
    Height : 352 pixels
    Display aspect ratio : 16/9
    Frame rate : 23.976 fps
    Resolution : 24 bits
    Colorimetry : 4:2:0
    Scan type : Progressive
    Bits/(Pixel*Frame) : 0.234
    Stream size : 205 MiB (88%)
    Writing library : XviD 1.2.0SMP (UTC 2006-01-08)
  Audio
    Format : MPEG Audio
    Format version : Version 1
    Format profile : Layer 3
    Codec ID : 55
    Codec ID/Hint : MP3
    Duration : 23mn 12s
    Bit rate mode : Variable
    Bit rate : 158 Kbps
    Nominal bit rate : 151 Kbps
    Channel(s) : 2 channels
    Sampling rate : 48.0 KHz
    Resolution : 16 bits
    Stream size : 26.3 MiB (11%)
    Alignment : Aligned on interleaves
    Interleave, duration : 24 ms (0.58 video frame)
    Writing library : LAME3.93 
    Encoding settings : ABR


--------------------
[Systeminfo]
--------------------
CPU 0: 2394MHz, Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz, x86 Family 6 Model 15 Stepping 6
CPU 1: 2394MHz, Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz, x86 Family 6 Model 15 Stepping 6
OS: Windows NT Home Edition(Version 6.0 Build 6000) 
Video: NVIDIA GeForce 8800 GTX

DirectX: 9.0c(4.09.00.0904)
Memory: All: 2 094 976 KB, Available: 1 268 256 KB, Used: 39%
CodePage: 1252, Charset:1
Instruction: MMX MMX2 SSE SSE2 SSE3 64Bits 

[System Process]
System
smss.exe
csrss.exe
wininit.exe
csrss.exe
services.exe
lsass.exe
lsm.exe
winlogon.exe
svchost.exe
nvvsvc.exe
svchost.exe
svchost.exe
svchost.exe
svchost.exe
svchost.exe
audiodg.exe
SLsvc.exe
svchost.exe
rundll32.exe
svchost.exe
AAWService.exe
spoolsv.exe
svchost.exe
dwm.exe
taskeng.exe
explorer.exe
AppleMobileDeviceService.exe
avgwdsvc.exe
mDNSResponder.exe
iviRegMgr.exe
mysqld-nt.exe
PnkBstrA.exe
PnkBstrB.exe
avgrsx.exe
svchost.exe
svchost.exe
svchost.exe
SearchIndexer.exe
unsecapp.exe
alg.exe
taskeng.exe
WmiPrvSE.exe
MSASCui.exe
CTHELPER.EXE
CTXFIHLP.EXE
AAWTray.exe
avgtray.exe
jusched.exe
reader_sl.exe
rundll32.exe
wmpnscfg.exe
wmpnetwk.exe
CTXFISPI.EXE
firefox.exe
SearchProtocolHost.exe
SearchFilterHost.exe
KMPlayer.exe
Not sure which part of this is vital.. this is version 1.33 but like I thought same problem.. I also would like to add that I didn't have the "freeze" problem when I was using a really really old version.. not sure which exactly =/ .. but the problem I had then was that the subtitles didn't work at all.. otherwise I would have kept the old version since I only play mkv and sometimes avi..

Any help would be much appriciated.. I hope this helps at all =) ty for taking the time to try to help me

// Robin
Last edited by mad : 04-24-2009 at 01:37 AM. Reason: code box
mad's Avatar
Retired moderator
 
Join Date:  Jan 2006
Location:  Slovakia
Posts:  2,581
#4 | Link | Posted 04-24-2009 Quote
1. Download and install the 1434 build (you have 1433)
2. Reset KMP (F2 - reset current preset ... at the bottom)
3. Change the video renderer (e.g. VMR9 Renderless, Haali V.R. (if installed), EVR C/A...) - turn KMP off and on to let the changes take effect
4. Enable KMP video transform filter (F2 - Video Processing - General tab - Always use)
5. Enable KMP external subtitle module (F2 - Subtitle processing - Multi-sub/etc - Advanced - enable)
6. report back how it went
i5 750 / 4GB RAM 1333Mhz / HD 5850 1GB / Windows 7 64-bit
New Member
 
Join Date:  Apr 2009
Posts:  5
#5 | Link | Posted 04-25-2009 Quote
Quote:
Originally Posted by mad View Post
1. Download and install the 1434 build (you have 1433)
2. Reset KMP (F2 - reset current preset ... at the bottom)
3. Change the video renderer (e.g. VMR9 Renderless, Haali V.R. (if installed), EVR C/A...) - turn KMP off and on to let the changes take effect
4. Enable KMP video transform filter (F2 - Video Processing - General tab - Always use)
5. Enable KMP external subtitle module (F2 - Subtitle processing - Multi-sub/etc - Advanced - enable)
6. report back how it went
Ty for this response I will try it soon, just thought I'd let you know I appriciate you helping me

Been keeping busy with other things than sitting by the computer for once, back now :P

// Robin
New Member
 
Join Date:  Apr 2009
Posts:  5
#6 | Link | Wohoo!!, Posted 04-25-2009 Quote
Quote:
Originally Posted by mad View Post
1. Download and install the 1434 build (you have 1433)
2. Reset KMP (F2 - reset current preset ... at the bottom)
3. Change the video renderer (e.g. VMR9 Renderless, Haali V.R. (if installed), EVR C/A...) - turn KMP off and on to let the changes take effect
4. Enable KMP video transform filter (F2 - Video Processing - General tab - Always use)
5. Enable KMP external subtitle module (F2 - Subtitle processing - Multi-sub/etc - Advanced - enable)
6. report back how it went
YOU SIR! Is the bees knees, the shit! I tried using Haali but then it just froze when I started a movie. So I changed to VMR9 Renderless filter and changed the other options as you recommended.. And well .. it seems to be working perfectly now.. first time since using the "new" versions that I could close the KM player after I've started playing a video file... this is exellent!

Thanks alot! Would've never figured this out by myself and as I mentioned searched forums for a long time not finding any solutions or even close too it..
mad's Avatar
Retired moderator
 
Join Date:  Jan 2006
Location:  Slovakia
Posts:  2,581
#7 | Link | Posted 04-26-2009 Quote
Quote:
Originally Posted by strajfen View Post
I tried using Haali but then it just froze when I started a movie.
I am personally using Haali´s V.R. (it needs to be installed separately). But if VMR9 is working for you, that´s fine.
Quote:
Originally Posted by strajfen View Post
first time since using the "new" versions that I could close the KM player after I've started playing a video file
That is probably because the KMP video transform filter is not enabled by default and probably something system related made KMP crash. And Overlay Mixer does not play nice with Vista (but don´t use Overlay Mixer if you have a good PC with a good graphic card anyway).
i5 750 / 4GB RAM 1333Mhz / HD 5850 1GB / Windows 7 64-bit
New Member
 
Join Date:  Apr 2009
Posts:  5
#8 | Link | Posted 04-27-2009 Quote
Quote:
Originally Posted by mad View Post
I am personally using Haali´s V.R. (it needs to be installed separately). But if VMR9 is working for you, that´s fine.

That is probably because the KMP video transform filter is not enabled by default and probably something system related made KMP crash. And Overlay Mixer does not play nice with Vista (but don´t use Overlay Mixer if you have a good PC with a good graphic card anyway).
I might check out Haali's V.R but since VMR9 is working so well atm I'm sticking too it =)

TY guys for the advice !

// Robin
New Member
 
Join Date:  May 2009
Posts:  1
#9 | Link | Posted 05-29-2009 Quote
Thanks for the explanations here - thought I was going to have to dump it
Legendary Member
 
Join Date:  Apr 2018
Posts:  412,262
#10 | Link | Posted 05-26-2018 Quote
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152dm19152
dm19152
«Previous Thread | Bug Reports | Next Thread»
Page 1 of 2: 1 2 >
Thread Tools
Display Modes
Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Supported by PANDORA.TV
All times are GMT +9. The time now is 05:00 AM.
Contact Us - The KMPlayer - Archive - Top